Technical issue

Incident Report for Blueprint

Resolved

This incident has been resolved.
Posted Mar 12, 2026 - 17:22 CDT

Investigating

We are currently experiencing an issue with file uploads and note generation. We are actively investigating and will provide regular updates.
Posted Mar 12, 2026 - 17:01 CDT
This incident affected: Clinician Application and API.